English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 95248 CVE descriptions
and 52540 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.100732
Category:Web application abuses
Title:MediaWiki 'profileinfo.php' Cross Site Scripting Vulnerability
Summary:Determine if installed MediaWiki version is vulnerable
Description:Description:
Overview:
MediaWiki is prone to a cross-site scripting vulnerability because it
fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code
in the browser of an unsuspecting user in the context of the affected
site. This may let the attacker steal cookie-based authentication
credentials and launch other attacks.

Versions prior to MediaWiki 1.15.5 and 1.16.0 are vulnerable.

Solution:
Updates are available. Please see the references for more information.

References:
https://www.securityfocus.com/bid/42024
http://lists.wikimedia.org/pipermail/mediawiki-announce/2010-July/000092.html
http://wikipedia.sourceforge.net/

CVSS Score:
2.6

CVSS Vector:
AV:N/AC:H/Au:N/C:N/I:P/A:N

Cross-Ref: BugTraq ID: 42024
Common Vulnerability Exposure (CVE) ID: CVE-2010-2788
http://lists.wikimedia.org/pipermail/mediawiki-announce/2010-July/000092.html
http://openwall.com/lists/oss-security/2010/07/29/4
http://lists.fedoraproject.org/pipermail/package-announce/2011-April/058588.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-April/059235.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-April/059232.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-April/058910.html
http://www.securityfocus.com/bid/42024
CopyrightThis script is Copyright (C) 2010 Greenbone Networks GmbH

This is only one of 52540 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2016 E-Soft Inc. All rights reserved.