Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2019-3859
Description:An out of bounds read flaw was discovered in libssh2 before 1.8.1 in the _libssh2_packet_require and _libssh2_packet_requirev functions. A remote attacker who compromises a SSH server may be able to cause a Denial of Service or read data in the client memory.
Test IDs: 1.3.6.1.4.1.25623.1.0.891730   1.3.6.1.4.1.25623.1.0.852464   1.3.6.1.4.1.25623.1.0.852460   1.3.6.1.4.1.25623.1.1.4.2019.1060.1   1.3.6.1.4.1.25623.1.1.4.2019.14031.1   1.3.6.1.4.1.25623.1.1.4.2019.1059.1  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2019-3859
BugTraq ID: 107485
http://www.securityfocus.com/bid/107485
Bugtraq: 20190319 [slackware-security] libssh2 (SSA:2019-077-01) (Google Search)
https://seclists.org/bugtraq/2019/Mar/25
Bugtraq: 20190415 [SECURITY] [DSA 4431-1] libssh2 security update (Google Search)
https://seclists.org/bugtraq/2019/Apr/25
Debian Security Information: DSA-4431 (Google Search)
https://www.debian.org/security/2019/dsa-4431
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5DK6VO2CEUTAJFYIKWNZKEKYMYR3NO2O/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XCWEA5ZCLKRDUK62QVVYMFWLWKOPX3LO/
http://packetstormsecurity.com/files/152136/Slackware-Security-Advisory-libssh2-Updates.html
https://www.libssh2.org/CVE-2019-3859.html
https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
https://lists.debian.org/debian-lts-announce/2019/03/msg00032.html
https://lists.debian.org/debian-lts-announce/2019/04/msg00006.html
https://lists.debian.org/debian-lts-announce/2019/07/msg00024.html
http://www.openwall.com/lists/oss-security/2019/03/18/3
SuSE Security Announcement: openSUSE-SU-2019:1075 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00040.html
SuSE Security Announcement: openSUSE-SU-2019:1109 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00003.html
SuSE Security Announcement: openSUSE-SU-2019:1290 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00102.html
SuSE Security Announcement: openSUSE-SU-2019:1291 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00103.html




© 1998-2021 E-Soft Inc. All rights reserved.