English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 95248 CVE descriptions
and 52540 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.51117
Category:Red Hat Local Security Checks
Title:RedHat Security Advisory RHSA-2004:245
Summary:Redhat Security Advisory RHSA-2004:245
Description:Description:

The remote host is missing updates announced in
advisory RHSA-2004:245.

The Apache HTTP Server is a powerful, full-featured, efficient, and
freely-available Web server.

A buffer overflow was found in the Apache proxy module, mod_proxy, which
can be triggered by receiving an invalid Content-Length header. In order
to exploit this issue, an attacker would need an Apache installation
that was configured as a proxy to connect to a malicious site. This would
cause the Apache child processing the request to crash. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name
CVE-2004-0492 to this issue.

On Red Hat Enterprise Linux platforms Red Hat believes this issue cannot
lead to remote code execution. This issue also does not represent a Denial
of Service attack as requests will continue to be handled by other Apache
child processes.

A stack buffer overflow was discovered in mod_ssl which can be triggered if
using the FakeBasicAuth option. If mod_ssl is sent a client certificate
with a subject DN field longer than 6000 characters, a stack overflow can
occur if FakeBasicAuth has been enabled. In order to exploit this issue
the carefully crafted malicious certificate would have to be signed by a
Certificate Authority which mod_ssl is configured to trust. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name
CVE-2004-0488 to this issue.

This update also fixes a DNS handling bug in mod_proxy.

The mod_auth_digest module is now included in the Apache package and should
be used instead of mod_digest for sites requiring Digest authentication.

Red Hat Enterprise Linux 2.1 users of the Apache HTTP Server should upgrade
to these erratum packages, which contains Apache version 1.3.27 with
backported patches correcting these issues.

Solution:
Please note that this update is available via
Red Hat Network. To use Red Hat Network, launch the Red
Hat Update Agent with the following command: up2date

http://rhn.redhat.com/errata/RHSA-2004-245.html
http://www.apacheweek.com/issues/04-06-11#security

Risk factor : Critical

CVSS Score:
10.0

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2004-0488
http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/021610.html
Debian Security Information: DSA-532 (Google Search)
http://www.debian.org/security/2004/dsa-532
https://bugzilla.fedora.us/show_bug.cgi?id=1888
HPdes Security Advisory: SSRT4777
http://marc.theaimsgroup.com/?l=bugtraq&m=109181600614477&w=2
HPdes Security Advisory: SSRT4788
http://marc.theaimsgroup.com/?l=bugtraq&m=109215056218824&w=2
http://www.mandriva.com/security/advisories?name=MDKSA-2004:054
http://www.mandriva.com/security/advisories?name=MDKSA-2004:055
http://www.redhat.com/support/errata/RHSA-2005-816.html
http://www.trustix.net/errata/2004/0031/
Bugtraq: 20040527 [OpenPKG-SA-2004.026] OpenPKG Security Advisory (apache) (Google Search)
http://marc.theaimsgroup.com/?l=bugtraq&m=108567431823750&w=2
Bugtraq: 20040601 TSSA-2004-008 - apache (Google Search)
http://marc.theaimsgroup.com/?l=bugtraq&m=108619129727620&w=2
http://security.gentoo.org/glsa/glsa-200406-05.xml
RedHat Security Advisories: RHSA-2004:245
http://rhn.redhat.com/errata/RHSA-2004-245.html
http://www.redhat.com/support/errata/RHSA-2004-342.html
http://www.redhat.com/support/errata/RHSA-2004-405.html
SGI Security Advisory: 20040605-01-U
ftp://patches.sgi.com/support/free/security/advisories/20040605-01-U.asc
BugTraq ID: 10355
http://www.securityfocus.com/bid/10355
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11458
XForce ISS Database: apache-modssl-uuencode-bo(16214)
http://xforce.iss.net/xforce/xfdb/16214
Common Vulnerability Exposure (CVE) ID: CVE-2004-0492
http://seclists.org/lists/fulldisclosure/2004/Jun/0296.html
http://www.guninski.com/modproxy1.html
Bugtraq: 20040611 [OpenPKG-SA-2004.029] OpenPKG Security Advisory (apache) (Google Search)
http://marc.theaimsgroup.com/?l=bugtraq&m=108711172710140&w=2
Debian Security Information: DSA-525 (Google Search)
http://www.debian.org/security/2004/dsa-525
https://bugzilla.fedora.us/show_bug.cgi?id=1737
HPdes Security Advisory: HPSBOV02683
http://marc.info/?l=bugtraq&m=130497311408250&w=2
HPdes Security Advisory: SSRT090208
http://www.mandriva.com/security/advisories?name=MDKSA-2004:065
http://sunsolve.sun.com/search/document.do?assetkey=1-26-57628-1
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101555-1
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101841-1
CERT/CC vulnerability note: VU#541310
http://www.kb.cert.org/vuls/id/541310
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:4863
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:100112
http://secunia.com/advisories/11841
XForce ISS Database: apache-modproxy-contentlength-bo(16387)
http://xforce.iss.net/xforce/xfdb/16387
CopyrightCopyright (c) 2005 E-Soft Inc. http://www.securityspace.com

This is only one of 52540 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2016 E-Soft Inc. All rights reserved.