Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.1.4.2015.2221.1
Category:SuSE Local Security Checks
Title:SUSE: Security Advisory (SUSE-SU-2015:2221-1)
Summary:The remote host is missing an update for the 'wpa_supplicant' package(s) announced via the SUSE-SU-2015:2221-1 advisory.
Description:Summary:
The remote host is missing an update for the 'wpa_supplicant' package(s) announced via the SUSE-SU-2015:2221-1 advisory.

Vulnerability Insight:
wpa_supplicant was updated to fix two security issues.
These security issues were fixed:
- CVE-2015-4142: Integer underflow in the WMM Action frame parser in
hostapd and wpa_supplicant, when used for AP mode MLME/SME
functionality, allowed remote attackers to cause a denial of service
(crash) via a crafted frame, which triggers an out-of-bounds read
(bsc#930078).
- CVE-2015-4141: The WPS UPnP function in hostapd, when using WPS AP, and
wpa_supplicant, when using WPS external registrar (ER), allowed remote
attackers to cause a denial of service (crash) via a negative chunk
length, which triggered an out-of-bounds read or heap-based buffer
overflow (bsc#930077).

Affected Software/OS:
'wpa_supplicant' package(s) on SUSE Linux Enterprise Server for VMWare 11-SP3, SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Server 11-SP3, SUSE Linux Enterprise Desktop 11-SP4, SUSE Linux Enterprise Desktop 11-SP3

Solution:
Please install the updated package(s).

CVSS Score:
4.3

CVSS Vector:
AV:N/AC:M/Au:N/C:N/I:N/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2015-4141
Debian Security Information: DSA-3397 (Google Search)
http://www.debian.org/security/2015/dsa-3397
https://security.gentoo.org/glsa/201606-17
http://www.openwall.com/lists/oss-security/2015/05/09/4
http://www.openwall.com/lists/oss-security/2015/05/31/6
SuSE Security Announcement: openSUSE-SU-2015:1030 (Google Search)
http://lists.opensuse.org/opensuse-updates/2015-06/msg00019.html
http://www.ubuntu.com/usn/USN-2650-1
Common Vulnerability Exposure (CVE) ID: CVE-2015-4142
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172655.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171401.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172608.html
http://www.openwall.com/lists/oss-security/2015/05/09/5
RedHat Security Advisories: RHSA-2015:1090
http://rhn.redhat.com/errata/RHSA-2015-1090.html
RedHat Security Advisories: RHSA-2015:1439
http://rhn.redhat.com/errata/RHSA-2015-1439.html
http://www.securitytracker.com/id/1032625
CopyrightCopyright (C) 2021 Greenbone Networks GmbH

This is only one of 97459 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.