Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.1.4.2018.0486.1
Category:SuSE Local Security Checks
Title:SUSE: Security Advisory (SUSE-SU-2018:0486-1)
Summary:The remote host is missing an update for the 'ImageMagick' package(s) announced via the SUSE-SU-2018:0486-1 advisory.
Description:Summary:
The remote host is missing an update for the 'ImageMagick' package(s) announced via the SUSE-SU-2018:0486-1 advisory.

Vulnerability Insight:
This update for ImageMagick fixes the following issues:
- CVE-2017-9407: In ImageMagick, the ReadPALMImage function in palm.c
allowed attackers to cause a denial of service (memory leak) via a
crafted file. (bsc#1042824)
- CVE-2017-11448: The ReadJPEGImage function in coders/jpeg.c in
ImageMagick allowed remote attackers to obtain sensitive information
from uninitialized memory locations via a crafted file. (bsc#1049375)
- CVE-2017-11450: A remote denial of service in coders/jpeg.c was fixed
(bsc#1049374)
- CVE-2017-11537: When ImageMagick processed a crafted file in convert, it
can lead to a Floating Point Exception (FPE) in the WritePALMImage()
function in coders/palm.c, related to an incorrect bits-per-pixel
calculation. (bsc#1050048)
- CVE-2017-12418: ImageMagick had memory leaks in the parse8BIMW and
format8BIM functions in coders/meta.c, related to the WriteImage
function in MagickCore/constitute.c. (bsc#1052207)
- CVE-2017-12432: In ImageMagick, a memory exhaustion vulnerability was
found in the function ReadPCXImage in coders/pcx.c, which allowed
attackers to cause a denial of service. (bsc#1052254)
- CVE-2017-12654: The ReadPICTImage function in coders/pict.c in
ImageMagick allowed attackers to cause a denial of service (memory leak)
via a crafted file. (bsc#1052761)
- CVE-2017-12664: ImageMagick had a memory leak vulnerability in
WritePALMImage in coders/palm.c. (bsc#1052750)
- CVE-2017-12665: ImageMagick had a memory leak vulnerability in
WritePICTImage in coders/pict.c. (bsc#1052747)
- CVE-2017-12668: ImageMagick had a memory leak vulnerability in
WritePCXImage in coders/pcx.c. (bsc#1052688)
- CVE-2017-13058: In ImageMagick, a memory leak vulnerability was found in
the function WritePCXImage in coders/pcx.c, which allowed attackers to
cause a denial of service via a crafted file. (bsc#1055069)
- CVE-2017-14224: A heap-based buffer overflow in WritePCXImage in
coders/pcx.c could lead to denial of service or code execution.
(bsc#1058009)
- CVE-2017-17885: In ImageMagick, a memory leak vulnerability was found in
the function ReadPICTImage in coders/pict.c, which allowed attackers to
cause a denial of service via a crafted PICT image file. (bsc#1074119)
- CVE-2017-18028: A memory exhaustion in the function ReadTIFFImage in
coders/tiff.c was fixed. (bsc#1076182)
- CVE-2018-6405: In the ReadDCMImage function in coders/dcm.c in
ImageMagick, each redmap, greenmap, and bluemap variable can be
overwritten by a new pointer. The previous pointer is lost, which leads
to a memory leak. This allowed remote attackers to cause a denial of
service. (bsc#1078433)
- CVE-2017-12427: ProcessMSLScript coders/msl.c allowed remote attackers
to cause a DoS (bsc#1052248)
- CVE-2017-12566: A memory leak in ReadMVGImage in coders/mvg.c, could
have allowed attackers to cause DoS (bsc#1052472)
- CVE-2017-11638, CVE-2017-11642: A NULL pointer dereference in
theW... [Please see the references for more information on the vulnerabilities]

Affected Software/OS:
'ImageMagick' package(s) on SUSE Linux Enterprise Software Development Kit 11-SP4, SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Debuginfo 11-SP4

Solution:
Please install the updated package(s).

CVSS Score:
7.8

CVSS Vector:
AV:N/AC:L/Au:N/C:N/I:N/A:C

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2017-9407
Common Vulnerability Exposure (CVE) ID: CVE-2018-6405
https://usn.ubuntu.com/3681-1/
CopyrightCopyright (C) 2021 Greenbone Networks GmbH

This is only one of 97459 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.