Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.1.4.2019.1019.1
Category:SuSE Local Security Checks
Title:SUSE: Security Advisory (SUSE-SU-2019:1019-1)
Summary:The remote host is missing an update for the 'ImageMagick' package(s) announced via the SUSE-SU-2019:1019-1 advisory.
Description:Summary:
The remote host is missing an update for the 'ImageMagick' package(s) announced via the SUSE-SU-2019:1019-1 advisory.

Vulnerability Insight:
This update for ImageMagick fixes the following issues:

Security issues fixed:
CVE-2019-9956: Fixed a stack-based buffer overflow in PopHexPixel()
(bsc#1130330).

CVE-2019-10650: Fixed a heap-based buffer over-read in WriteTIFFImage()
(bsc#1131317).

CVE-2019-11007: Fixed a heap-based buffer overflow in ReadMNGImage()
(bsc#1132060).

CVE-2019-11008: Fixed a heap-based buffer overflow in WriteXWDImage()
(bsc#1132054).
Added extra -config- packages with Postscript/EPS/PDF readers still
enabled.

Removing the PS decoders is used to harden ImageMagick against security issues within ghostscript. Enabling them might impact security.
(bsc#1122033)

These are two packages that can be selected:

- ImageMagick-config-7-SUSE: This has the PS decoders disabled.
- ImageMagick-config-7-upstream: This has the PS decoders enabled.

Depending on your local needs install either one of them. The default is the -SUSE configuration.

Affected Software/OS:
'ImageMagick' package(s) on SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Desktop Applications 15

Solution:
Please install the updated package(s).

CVSS Score:
6.8

CVSS Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2019-9956
BugTraq ID: 107546
http://www.securityfocus.com/bid/107546
BugTraq ID: 107672
http://www.securityfocus.com/bid/107672
Bugtraq: 20190429 [SECURITY] [DSA 4436-1] imagemagick security update (Google Search)
https://seclists.org/bugtraq/2019/Apr/37
Debian Security Information: DSA-4436 (Google Search)
https://www.debian.org/security/2019/dsa-4436
https://github.com/ImageMagick/ImageMagick/issues/1523
https://lists.debian.org/debian-lts-announce/2019/05/msg00015.html
SuSE Security Announcement: openSUSE-SU-2019:1320 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00006.html
SuSE Security Announcement: openSUSE-SU-2019:1331 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00010.html
https://usn.ubuntu.com/4034-1/
CopyrightCopyright (C) 2021 Greenbone Networks GmbH

This is only one of 97459 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.