Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.1.4.2020.0069.1
Category:SuSE Local Security Checks
Title:SUSE: Security Advisory (SUSE-SU-2020:0069-1)
Summary:The remote host is missing an update for the 'openssl-1_1' package(s) announced via the SUSE-SU-2020:0069-1 advisory.
Description:Summary:
The remote host is missing an update for the 'openssl-1_1' package(s) announced via the SUSE-SU-2020:0069-1 advisory.

Vulnerability Insight:
This update for openssl-1_1 fixes the following issues:

Security issue fixed:
CVE-2019-1551: Fixed an overflow bug in the x64_64 Montgomery squaring
procedure used in exponentiation with 512-bit moduli (bsc#1158809).

Various FIPS related improvements were done:
FIPS: Backport SSH KDF to openssl (jsc#SLE-8789, bsc#1157775).

Port FIPS patches from SLE-12 (bsc#1158101).

Use SHA-2 in the RSA pairwise consistency check (bsc#1155346).

Affected Software/OS:
'openssl-1_1' package(s) on SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1, SUSE Linux Enterprise Module for Basesystem 15-SP1

Solution:
Please install the updated package(s).

CVSS Score:
5.0

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:N/A:N

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2019-1551
Bugtraq: 20191225 [slackware-security] openssl (SSA:2019-354-01) (Google Search)
https://seclists.org/bugtraq/2019/Dec/39
Bugtraq: 20191229 [SECURITY] [DSA 4594-1] openssl1.0 security update (Google Search)
https://seclists.org/bugtraq/2019/Dec/46
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=419102400a2811582a7a3d4a4e317d72e5ce0a8f
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=f1c5eea8a817075d31e43f5876993c6710238c98
https://security.netapp.com/advisory/ntap-20191210-0001/
https://www.openssl.org/news/secadv/20191206.txt
https://www.tenable.com/security/tns-2019-09
https://www.tenable.com/security/tns-2020-03
https://www.tenable.com/security/tns-2020-11
https://www.tenable.com/security/tns-2021-10
Debian Security Information: DSA-4594 (Google Search)
https://www.debian.org/security/2019/dsa-4594
Debian Security Information: DSA-4855 (Google Search)
https://www.debian.org/security/2021/dsa-4855
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/EXDDAOWSAIEFQNBHWYE6PPYFV4QXGMCD/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DDHOAATPWJCXRNFMJ2SASDBBNU5RJONY/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XVEP3LAK4JSPRXFO4QF4GG2IVXADV3SO/
https://security.gentoo.org/glsa/202004-10
http://packetstormsecurity.com/files/155754/Slackware-Security-Advisory-openssl-Updates.html
https://www.oracle.com/security-alerts/cpuApr2021.html
https://www.oracle.com/security-alerts/cpujan2021.html
https://www.oracle.com/security-alerts/cpujul2020.html
SuSE Security Announcement: openSUSE-SU-2020:0062 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00030.html
https://usn.ubuntu.com/4376-1/
https://usn.ubuntu.com/4504-1/
CopyrightCopyright (C) 2021 Greenbone Networks GmbH

This is only one of 97459 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.