English | Deutsch | Español | Português
 UserID:
 Passwd:
new user
 About:   Dedicated  | Advanced  | Standard  | Recurring  | No Risk  | Desktop  | Basic  | Single  | Security Seal  | FAQ
  Price/Feature Summary  | Order  | New Vulnerabilities  | Confidentiality  | Vulnerability Search
 Vulnerability   
Search   
    Search 92446 CVE descriptions
and 51095 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.0.58502
Category:Mandrake Local Security Checks
Title:Mandrake Security Advisory MDKSA-2007:164 (tetex)
Summary:Mandrake Security Advisory MDKSA-2007:164 (tetex)
Description:Description:

The remote host is missing an update to tetex
announced via advisory MDKSA-2007:164.

Maurycy Prodeus found an integer overflow vulnerability in the way
various PDF viewers processed PDF files. An attacker could create
a malicious PDF file that could cause tetex to crash and possibly
execute arbitrary code open a user opening the file.

In addition, tetex contains an embedded copy of the GD library which
suffers from a number of bugs which potentially lead to denial of
service and possibly other issues.

Integer overflow in gdImageCreateTrueColor function in the GD Graphics
Library (libgd) before 2.0.35 allows user-assisted remote attackers
to have unspecified remote attack vectors and impact. (CVE-2007-3472)

The gdImageCreateXbm function in the GD Graphics Library (libgd)
before 2.0.35 allows user-assisted remote attackers to cause a denial
of service (crash) via unspecified vectors involving a gdImageCreate
failure. (CVE-2007-3473)

Multiple unspecified vulnerabilities in the GIF reader in the
GD Graphics Library (libgd) before 2.0.35 allow user-assisted
remote attackers to have unspecified attack vectors and
impact. (CVE-2007-3474)

The GD Graphics Library (libgd) before 2.0.35 allows user-assisted
remote attackers to cause a denial of service (crash) via a GIF image
that has no global color map. (CVE-2007-3475)

Array index error in gd_gif_in.c in the GD Graphics Library (libgd)
before 2.0.35 allows user-assisted remote attackers to cause
a denial of service (crash and heap corruption) via large color
index values in crafted image data, which results in a segmentation
fault. (CVE-2007-3476)

The (a) imagearc and (b) imagefilledarc functions in GD Graphics
Library (libgd) before 2.0.35 allows attackers to cause a denial
of service (CPU consumption) via a large (1) start or (2) end angle
degree value. (CVE-2007-3477)

Race condition in gdImageStringFTEx (gdft_draw_bitmap) in gdft.c in the
GD Graphics Library (libgd) before 2.0.35 allows user-assisted remote
attackers to cause a denial of service (crash) via unspecified vectors,
possibly involving truetype font (TTF) support. (CVE-2007-3478)

Updated packages have been patched to prevent these issues.

Affected: 2007.0, 2007.1, Corporate 4.0

Solution:
To upgrade automatically use MandrakeUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

https://secure1.securityspace.com/smysecure/catid.html?in=MDKSA-2007:164

Risk factor : High

CVSS Score:
6.8

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2007-3472
Bugtraq: 20070907 FLEA-2007-0052-1 gd (Google Search)
http://www.securityfocus.com/archive/1/archive/1/478796/100/0/threaded
http://bugs.libgd.org/?do=details&task_id=89
http://www.secweb.se/en/advisories/gd-gdimagecreatetruecolor-integer-overflow/
http://fedoranews.org/updates/FEDORA-2007-205.shtml
http://www.redhat.com/archives/fedora-package-announce/2007-September/msg00311.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052854.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052848.html
http://security.gentoo.org/glsa/glsa-200708-05.xml
http://security.gentoo.org/glsa/glsa-200711-34.xml
http://security.gentoo.org/glsa/glsa-200805-13.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2007:153
http://www.mandriva.com/security/advisories?name=MDKSA-2007:164
http://www.redhat.com/support/errata/RHSA-2008-0146.html
SuSE Security Announcement: SUSE-SR:2007:015 (Google Search)
http://www.novell.com/linux/security/advisories/2007_15_sr.html
http://www.trustix.org/errata/2007/0024/
BugTraq ID: 24651
http://www.securityfocus.com/bid/24651
http://osvdb.org/37745
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11067
http://secunia.com/advisories/42813
http://www.vupen.com/english/advisories/2007/2336
http://secunia.com/advisories/25855
http://secunia.com/advisories/25860
http://secunia.com/advisories/26272
http://secunia.com/advisories/26390
http://secunia.com/advisories/26415
http://secunia.com/advisories/26467
http://secunia.com/advisories/26663
http://secunia.com/advisories/26766
http://secunia.com/advisories/26856
http://secunia.com/advisories/29157
http://secunia.com/advisories/30168
http://www.vupen.com/english/advisories/2011/0022
XForce ISS Database: gd-imagecreatetruecolor-code-execution(35108)
http://xforce.iss.net/xforce/xfdb/35108
Common Vulnerability Exposure (CVE) ID: CVE-2007-3473
http://bugs.libgd.org/?do=details&task_id=94
http://osvdb.org/37744
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11806
XForce ISS Database: gd-imagecreatexbm-dos(35109)
http://xforce.iss.net/xforce/xfdb/35109
Common Vulnerability Exposure (CVE) ID: CVE-2007-3474
http://osvdb.org/37743
XForce ISS Database: gd-gifreader-unspecified(35110)
http://xforce.iss.net/xforce/xfdb/35110
Common Vulnerability Exposure (CVE) ID: CVE-2007-3475
http://www.libgd.org/ReleaseNote020035
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9728
Common Vulnerability Exposure (CVE) ID: CVE-2007-3476
Debian Security Information: DSA-1613 (Google Search)
http://www.debian.org/security/2008/dsa-1613
http://osvdb.org/37741
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10348
http://secunia.com/advisories/31168
Common Vulnerability Exposure (CVE) ID: CVE-2007-3477
http://osvdb.org/42062
Common Vulnerability Exposure (CVE) ID: CVE-2007-3478
http://bugs.php.net/bug.php?id=40578
http://osvdb.org/37740
Common Vulnerability Exposure (CVE) ID: CVE-2007-3387
Bugtraq: 20070814 FLEA-2007-0044-1 tetex tetex-dvips tetex-fonts (Google Search)
http://www.securityfocus.com/archive/1/archive/1/476508/100/0/threaded
Bugtraq: 20070814 FLEA-2007-0045-1 poppler (Google Search)
http://www.securityfocus.com/archive/1/archive/1/476519/30/5400/threaded
Bugtraq: 20070816 FLEA-2007-0046-1 cups (Google Search)
http://www.securityfocus.com/archive/1/archive/1/476765/30/5340/threaded
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=248194
http://bugs.gentoo.org/show_bug.cgi?id=187139
Debian Security Information: DSA-1347 (Google Search)
http://www.debian.org/security/2007/dsa-1347
Debian Security Information: DSA-1348 (Google Search)
http://www.debian.org/security/2007/dsa-1348
Debian Security Information: DSA-1349 (Google Search)
http://www.debian.org/security/2007/dsa-1349
Debian Security Information: DSA-1350 (Google Search)
http://www.debian.org/security/2007/dsa-1350
Debian Security Information: DSA-1352 (Google Search)
http://www.debian.org/security/2007/dsa-1352
Debian Security Information: DSA-1355 (Google Search)
http://www.debian.org/security/2007/dsa-1355
Debian Security Information: DSA-1354 (Google Search)
http://www.debian.org/security/2007/dsa-1354
Debian Security Information: DSA-1357 (Google Search)
http://www.debian.org/security/2007/dsa-1357
http://security.gentoo.org/glsa/glsa-200709-12.xml
http://www.gentoo.org/security/en/glsa/glsa-200710-08.xml
http://security.gentoo.org/glsa/glsa-200710-20.xml
http://security.gentoo.org/glsa/glsa-200709-17.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2007:162
http://www.mandriva.com/security/advisories?name=MDKSA-2007:158
http://www.mandriva.com/security/advisories?name=MDKSA-2007:159
http://www.mandriva.com/security/advisories?name=MDKSA-2007:160
http://www.mandriva.com/security/advisories?name=MDKSA-2007:161
http://www.mandriva.com/security/advisories?name=MDKSA-2007:163
http://www.mandriva.com/security/advisories?name=MDKSA-2007:165
http://www.redhat.com/support/errata/RHSA-2007-0730.html
http://www.redhat.com/support/errata/RHSA-2007-0720.html
http://www.redhat.com/support/errata/RHSA-2007-0729.html
http://www.redhat.com/support/errata/RHSA-2007-0732.html
http://www.redhat.com/support/errata/RHSA-2007-0735.html
http://www.redhat.com/support/errata/RHSA-2007-0731.html
SGI Security Advisory: 20070801-01-P
ftp://patches.sgi.com/support/free/security/advisories/20070801-01-P.asc
http://www.slackware.org/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.423670
http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.761882
SuSE Security Announcement: SUSE-SR:2007:016 (Google Search)
http://www.novell.com/linux/security/advisories/2007_16_sr.html
http://www.ubuntu.com/usn/usn-496-1
http://www.ubuntu.com/usn/usn-496-2
BugTraq ID: 25124
http://www.securityfocus.com/bid/25124
http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:11149
http://www.vupen.com/english/advisories/2007/2704
http://www.vupen.com/english/advisories/2007/2705
http://osvdb.org/40127
http://www.securitytracker.com/id?1018473
http://secunia.com/advisories/26188
http://secunia.com/advisories/26254
http://secunia.com/advisories/26255
http://secunia.com/advisories/26257
http://secunia.com/advisories/26278
http://secunia.com/advisories/26281
http://secunia.com/advisories/26283
http://secunia.com/advisories/26251
http://secunia.com/advisories/26293
http://secunia.com/advisories/26292
http://secunia.com/advisories/26307
http://secunia.com/advisories/26318
http://secunia.com/advisories/26342
http://secunia.com/advisories/26297
http://secunia.com/advisories/26343
http://secunia.com/advisories/26358
http://secunia.com/advisories/26325
http://secunia.com/advisories/26365
http://secunia.com/advisories/26370
http://secunia.com/advisories/26413
http://secunia.com/advisories/26410
http://secunia.com/advisories/26403
http://secunia.com/advisories/26405
http://secunia.com/advisories/26407
http://secunia.com/advisories/26432
http://secunia.com/advisories/26436
http://secunia.com/advisories/26468
http://secunia.com/advisories/26470
http://secunia.com/advisories/26425
http://secunia.com/advisories/26395
http://secunia.com/advisories/26514
http://secunia.com/advisories/26607
http://secunia.com/advisories/26862
http://secunia.com/advisories/27156
http://secunia.com/advisories/27281
http://secunia.com/advisories/27308
http://secunia.com/advisories/27637
http://secunia.com/advisories/26627
http://secunia.com/advisories/26982
CopyrightCopyright (c) 2007 E-Soft Inc. http://www.securityspace.com

This is only one of 51095 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

New User Registration
Email:
UserID:
Passwd:
Please email me your monthly newsletters, informing the latest services, improvements & surveys.
Please email me a vulnerability test announcement whenever a new test is added.
   Privacy
Registered User Login
 
UserID:   
Passwd:  

 Forgot userid or passwd?
Email/Userid:




Home | About Us | Contact Us | Partner Programs | Developer APIs | Privacy | Mailing Lists | Abuse
Security Audits | Managed DNS | Network Monitoring | Site Analyzer | Internet Research Reports
Web Probe | Whois

© 1998-2016 E-Soft Inc. All rights reserved.