Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:
Category:Web application abuses
Title:PHP 'php_parserr' Heap Based Buffer Overflow Vulnerability (Linux)
Summary:PHP is prone to a heap-based buffer overflow vulnerability.
PHP is prone to a heap-based buffer overflow vulnerability.

Vulnerability Insight:
The flaw is due to buffer overflow error
in the 'php_parserr' function in ext/standard/dns.c script.

Vulnerability Impact:
Successfully exploiting this issue allows remote
attackers to cause a denial of service (crash) and possibly execute arbitrary code
on the affected system.

Affected Software/OS:
PHP versions 5.6.x alpha and beta releases
before 5.6.0, 5.5.x before 5.5.14, 5.4.x before 5.4.30, 5.3.x before 5.3.29
on Linux

Update to PHP version 5.6.0 or 5.5.14 or
5.4.30 or 5.3.29 or later.

CVSS Score:

CVSS Vector:

Cross-Ref: BugTraq ID: 68007
Common Vulnerability Exposure (CVE) ID: CVE-2014-4049
Debian Security Information: DSA-2961 (Google Search)
HPdes Security Advisory: HPSBUX03102
HPdes Security Advisory: SSRT101681
RedHat Security Advisories: RHSA-2014:1765
RedHat Security Advisories: RHSA-2014:1766
SuSE Security Announcement: SUSE-SU-2014:0868 (Google Search)
SuSE Security Announcement: SUSE-SU-2014:0869 (Google Search)
SuSE Security Announcement: openSUSE-SU-2014:0841 (Google Search)
SuSE Security Announcement: openSUSE-SU-2014:0942 (Google Search)
CopyrightCopyright (C) 2016 Greenbone Networks GmbH

This is only one of 97459 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.

© 1998-2021 E-Soft Inc. All rights reserved.