Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

Test ID:1.3.6.1.4.1.25623.1.1.4.2015.1091.1
Category:SuSE Local Security Checks
Title:SUSE: Security Advisory (SUSE-SU-2015:1091-1)
Summary:The remote host is missing an update for the 'postgresql91' package(s) announced via the SUSE-SU-2015:1091-1 advisory.
Description:Summary:
The remote host is missing an update for the 'postgresql91' package(s) announced via the SUSE-SU-2015:1091-1 advisory.

Vulnerability Insight:
This update provides PostgreSQL 9.1.18, which brings fixes for security issues and other enhancements.
The following vulnerabilities have been fixed:
CVE-2015-3165: Avoid possible crash when client disconnects. (bsc#931972)
CVE-2015-3166: Consistently check for failure of the *printf(). (bsc#931973)
CVE-2015-3167: In contrib/pgcrypto, uniformly report decryption failures. (bsc#931974)
For a comprehensive list of changes, please refer to [link moved to references].
This update also includes changes in PostgreSQL's packaging to prepare for the migration to the new major version 9.4. (FATE#316970, bsc#907651)
Security Issues:
CVE-2015-3165 CVE-2015-3166 CVE-2015-3167

Affected Software/OS:
'postgresql91' package(s) on SUSE Linux Enterprise Software Development Kit 11 SP3, SUSE Linux Enterprise Server 11 SP3, SUSE Linux Enterprise Desktop 11 SP3

Solution:
Please install the updated package(s).

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Cross-Ref: Common Vulnerability Exposure (CVE) ID: CVE-2015-3165
http://lists.apple.com/archives/security-announce/2015/Sep/msg00004.html
BugTraq ID: 74787
http://www.securityfocus.com/bid/74787
Debian Security Information: DSA-3269 (Google Search)
http://www.debian.org/security/2015/dsa-3269
Debian Security Information: DSA-3270 (Google Search)
http://www.debian.org/security/2015/dsa-3270
https://security.gentoo.org/glsa/201507-20
RedHat Security Advisories: RHSA-2015:1194
http://rhn.redhat.com/errata/RHSA-2015-1194.html
RedHat Security Advisories: RHSA-2015:1195
http://rhn.redhat.com/errata/RHSA-2015-1195.html
RedHat Security Advisories: RHSA-2015:1196
http://rhn.redhat.com/errata/RHSA-2015-1196.html
http://www.ubuntu.com/usn/USN-2621-1
Common Vulnerability Exposure (CVE) ID: CVE-2015-3166
http://ubuntu.com/usn/usn-2621-1
http://www.postgresql.org/about/news/1587/
http://www.postgresql.org/docs/9.0/static/release-9-0-20.html
http://www.postgresql.org/docs/9.1/static/release-9-1-16.html
http://www.postgresql.org/docs/9.2/static/release-9-2-11.html
http://www.postgresql.org/docs/9.3/static/release-9-3-7.html
http://www.postgresql.org/docs/9.4/static/release-9-4-2.html
Common Vulnerability Exposure (CVE) ID: CVE-2015-3167
CopyrightCopyright (C) 2021 Greenbone Networks GmbH

This is only one of 97459 vulnerability tests in our test suite. Find out more about running a complete security audit.

To run a free test of this vulnerability against your system, register below.




© 1998-2021 E-Soft Inc. All rights reserved.