Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2012-5526
Description:CGI.pm module before 3.63 for Perl does not properly escape newlines in (1) Set-Cookie or (2) P3P headers, which might allow remote attackers to inject arbitrary headers into responses from applications that use CGI.pm.
Test IDs: 1.3.6.1.4.1.25623.1.0.803160   1.3.6.1.4.1.25623.1.0.803344   1.3.6.1.4.1.25623.1.0.123654   1.3.6.1.4.1.25623.1.0.892587   1.3.6.1.4.1.25623.1.0.864899   1.3.6.1.4.1.25623.1.0.831757   1.3.6.1.4.1.25623.1.0.864929   1.3.6.1.4.1.25623.1.0.864933   1.3.6.1.4.1.25623.1.0.864949   1.3.6.1.4.1.25623.1.0.702587  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2012-5526
BugTraq ID: 56562
http://www.securityfocus.com/bid/56562
Debian Security Information: DSA-2586 (Google Search)
http://www.debian.org/security/2012/dsa-2586
https://github.com/markstos/CGI.pm/pull/23
http://www.openwall.com/lists/oss-security/2012/11/15/6
RedHat Security Advisories: RHSA-2013:0685
http://rhn.redhat.com/errata/RHSA-2013-0685.html
http://www.securitytracker.com/id?1027780
http://secunia.com/advisories/51457
http://secunia.com/advisories/55314
http://www.ubuntu.com/usn/USN-1643-1
XForce ISS Database: perl-cgipm-header-injection(80098)
https://exchange.xforce.ibmcloud.com/vulnerabilities/80098




© 1998-2021 E-Soft Inc. All rights reserved.