Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2013-3567
Description:Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a crafted REST API call.
Test IDs: 1.3.6.1.4.1.25623.1.0.850554   1.3.6.1.4.1.25623.1.0.841483   1.3.6.1.4.1.25623.1.0.120436   1.3.6.1.4.1.25623.1.0.702715   1.3.6.1.4.1.25623.1.1.4.2013.1304.1  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2013-3567
Debian Security Information: DSA-2715 (Google Search)
http://www.debian.org/security/2013/dsa-2715
RedHat Security Advisories: RHSA-2013:1283
http://rhn.redhat.com/errata/RHSA-2013-1283.html
RedHat Security Advisories: RHSA-2013:1284
http://rhn.redhat.com/errata/RHSA-2013-1284.html
http://secunia.com/advisories/54429
SuSE Security Announcement: SUSE-SU-2013:1304 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00002.html
SuSE Security Announcement: openSUSE-SU-2013:1370 (Google Search)
http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00019.html
http://www.ubuntu.com/usn/USN-1886-1




© 1998-2021 E-Soft Inc. All rights reserved.