Vulnerability   
Search   
    Search 219043 CVE descriptions
and 99761 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2014-3597
Description:Multiple buffer overflows in the php_parserr function in ext/standard/dns.c in PHP before 5.4.32 and 5.5.x before 5.5.16 allow remote DNS servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted DNS record, related to the dns_get_record function and the dn_expand function. NOTE: this issue exists because of an incomplete fix for CVE-2014-4049.
Test IDs: 1.3.6.1.4.1.25623.1.0.123296   1.3.6.1.4.1.25623.1.0.123295  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2014-3597
http://lists.apple.com/archives/security-announce/2015/Apr/msg00001.html
BugTraq ID: 69322
http://www.securityfocus.com/bid/69322
Debian Security Information: DSA-3008 (Google Search)
http://www.debian.org/security/2014/dsa-3008
RedHat Security Advisories: RHSA-2014:1326
http://rhn.redhat.com/errata/RHSA-2014-1326.html
RedHat Security Advisories: RHSA-2014:1327
http://rhn.redhat.com/errata/RHSA-2014-1327.html
RedHat Security Advisories: RHSA-2014:1765
http://rhn.redhat.com/errata/RHSA-2014-1765.html
RedHat Security Advisories: RHSA-2014:1766
http://rhn.redhat.com/errata/RHSA-2014-1766.html
http://secunia.com/advisories/60609
http://secunia.com/advisories/60696
SuSE Security Announcement: openSUSE-SU-2014:1133 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-09/msg00024.html
SuSE Security Announcement: openSUSE-SU-2014:1245 (Google Search)
http://lists.opensuse.org/opensuse-updates/2014-09/msg00055.html
http://www.ubuntu.com/usn/USN-2344-1




© 1998-2021 E-Soft Inc. All rights reserved.