Vulnerability   
Search   
    Search 211766 CVE descriptions
and 97459 test descriptions,
access 10,000+ cross references.
Tests   CVE   All  

CVE ID:CVE-2018-5711
Description:gd_gif_in.c in the GD Graphics Library (aka libgd), as used in PHP before 5.6.33, 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1, has an integer signedness error that leads to an infinite loop via a crafted GIF file, as demonstrated by a call to the imagecreatefromgif or imagecreatefromstring PHP function. This is related to GetCode_ and gdImageCreateFromGifCtx.
Test IDs: 1.3.6.1.4.1.25623.1.0.891248   1.3.6.1.4.1.25623.1.0.874302   1.3.6.1.4.1.25623.1.0.874328   1.3.6.1.4.1.25623.1.0.875076   1.3.6.1.4.1.25623.1.0.843692   1.3.6.1.4.1.25623.1.0.891651   1.3.6.1.4.1.25623.1.1.4.2018.0260.1   1.3.6.1.4.1.25623.1.1.4.2018.0235.1  
Cross References: Common Vulnerability Exposure (CVE) ID: CVE-2018-5711
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3CZ2QADQTKRHTGB2AHD7J4QQNDLBEMM6/
https://security.gentoo.org/glsa/201903-18
https://www.oracle.com/security-alerts/cpuapr2020.html
https://lists.debian.org/debian-lts-announce/2018/01/msg00022.html
https://lists.debian.org/debian-lts-announce/2019/01/msg00028.html
RedHat Security Advisories: RHSA-2018:1296
https://access.redhat.com/errata/RHSA-2018:1296
RedHat Security Advisories: RHSA-2019:2519
https://access.redhat.com/errata/RHSA-2019:2519
https://usn.ubuntu.com/3755-1/




© 1998-2021 E-Soft Inc. All rights reserved.